Discussion:
sys_select: avoid warning
(too old to reply)
Bruno Haible
2017-05-15 17:36:38 UTC
Permalink
Raw Message
In gettext's use of gnulib, I'm seeing this warning:

./autogen.sh: generating configure in gettext-tools...
configure.ac:149: warning: AC_REQUIRE: `gl_HEADER_SYS_SELECT' was expanded before it was required
configure.ac:149: http://www.gnu.org/software/autoconf/manual/autoconf.html#Expanded-Before-Required
gnulib-m4/select.m4:7: gl_FUNC_SELECT is expanded from...
gnulib-m4/nanosleep.m4:14: gl_FUNC_NANOSLEEP is expanded from...
gnulib-m4/gnulib-comp.m4:614: gl_INIT is expanded from...
configure.ac:149: the top level

This patch fixes it.


2017-05-15 Bruno Haible <***@clisp.org>

sys_select: Avoid "was expanded before it was required" warning.
* modules/sys_select (configure.ac): Require, not invoke,
gl_HEADER_SYS_SELECT.

diff --git a/modules/sys_select b/modules/sys_select
index 97262bb..ab062a0 100644
--- a/modules/sys_select
+++ b/modules/sys_select
@@ -14,7 +14,7 @@ snippet/warn-on-use
sys_time

configure.ac:
-gl_HEADER_SYS_SELECT
+AC_REQUIRE([gl_HEADER_SYS_SELECT])
AC_PROG_MKDIR_P

Makefile.am:

Loading...