Discussion:
FYI: [PATCH] vasnprintf.c: avoid spurious warning from GCC 7
(too old to reply)
Jim Meyering
2016-10-02 19:12:25 UTC
Permalink
Raw Message
I want to build with bleeding edge GCC 7, and the following was
getting in my way, so I've just pushed the attached patch:

[PATCH] vasnprintf.c: avoid spurious warning from GCC 7

The presence of cpp directives renders this "FALLTHROUGH" comment
ineffective, so does not suppress the -Wimplicit-fallthrough warning
from GCC 7 built from git on 2016-10-02.
* lib/vasnprintf.c (VASNPRINTF): Move comment down past two cpp
directives, so that it takes effect once again. This is clearly
not a proper change, and I will revert it once this bug is fixed:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=77817

Loading...