Discussion:
gnulib-related warnings while running testsuite of wget-1.18.109-4734
(too old to reply)
Antonio Diaz Diaz
2017-02-07 16:45:07 UTC
Permalink
Raw Message
Hello,

While testing wget-1.18.109-4734 on a 32-bit GNU/Linux system with
glibc-2.5 and gcc-4.1.2, I got these warnings from gnulib files:

--------------------------------------------------------------------
mktime.c: In function 'mktime_internal':
mktime.c:355: warning: comparison is always false due to limited range
of data type
mktime.c:355: warning: comparison is always false due to limited range
of data type

In file included from regex.c:72:
regexec.c: In function 're_search_2_stub':
regexec.c:360: warning: comparison is always false due to limited range
of data type
regexec.c:360: warning: comparison is always false due to limited range
of data type
--------------------------------------------------------------------

Hope this helps.

Thanks,
Antonio.
Paul Eggert
2017-02-07 17:03:05 UTC
Permalink
Raw Message
I assume you're using an older version of GCC. Newer GCCs should be OK,
and it's not worth the trouble to pacify the older ones.
Antonio Diaz Diaz
2017-02-07 18:33:19 UTC
Permalink
Raw Message
Post by Paul Eggert
I assume you're using an older version of GCC. Newer GCCs should be OK,
Yes, this machine has gcc-4.1.2 instaled.
Post by Paul Eggert
and it's not worth the trouble to pacify the older ones.
I just reported this here because it is part of a larger report to
bug-wget and the maintainer of wget asked me to report it, but it is not
important.


Thanks for the answer.
Antonio.

Loading...