Discussion:
INT_MULTIPLY_WRAPV compile warning
(too old to reply)
Pádraig Brady
2017-01-25 11:21:02 UTC
Permalink
Raw Message
FYI when compiling coreutils on centos 5 (gcc-4.1.2) I noticed:
any use of INT_MULTIPLY_WRAPV gave the warning:

src/pr.c:1274: warning: comparison is always false due to limited range of data type
Paul Eggert
2017-01-25 15:42:27 UTC
Permalink
Raw Message
Post by Pádraig Brady
src/pr.c:1274: warning: comparison is always false due to limited range of data type
I've seen that too. It's a false alarm that doesn't otherwise affect the
build, and is not worth worrying about. (CentOS 5, huh? Do you drive a
Model T too? :-)

Loading...